cmld. - Partial Outage of the “Waterfall” Node – Incident details

Sosanie Ebla Premium (api.sosanie-ebla-bot-premium.vapronva.pw) experiencing partial outage

Partial Outage of the “Waterfall” Node

Resolved
Degraded performance
Started over 2 years agoLasted 33 minutes
Updates
  • Resolved
    Resolved

    The issue has been resolved — the node is replying to requests normally.

    To remove any potential future occurrence of that issue, a notification system for anomalies has been added and tested to the infrastructure stack.

  • Monitoring
    Monitoring

    The fix has been implemented (reloading the node stack).

  • Identified
    Identified

    The abnormal CPU and disk usage has been identified at the Waterfall node.

    The root cause is declared to be a MariaDB process that leaked memory bit-by-bit over the past days leading to no RAM being left for other processes.

  • Investigating
    Investigating

    We are currently investigating this incident.
    As of now, seems like the Waterfall node is unresponsive to some requests.